Window Titles show __ Instead of Accents and other Characters

Hello!

My native language has some accents, and if i’m on a webpage which has accents in its title, the browser’s tab on the panel shows a “__” instead of the accented letter. For example: Here is this webpage: link. On the panel this should be appear: Épeler - French Verb Conjugation, but instead this appears on the browser’s tab at the panel: __peler - French Verb Conjugation. I’ve checked the locales in dom0 with the command locale and everything seems good, every locale is set to en_US.utf8. With this setup it works perfectly fine on other linux system. Is it something i should check and set in Qubes to work with accents?

Thanks any help!

For safety purposes only ascii text (non-accent) letters titles are allowed. There is an option to disable that.

allow_utf8_titles - allow the use of UTF-8 in window titles; otherwise, non-ASCII characters are replaced by an underscore.

:warning: But first make sure you understand the risks. As far as I understand complex characters are far too complex and require a high degree of scrutiny (see UTR #36: Unicode Security Considerations).

So I would discourage enabling this feature.

1 Like

Thanks!

I was not aware about it. I t is just a small cosmetic issue, and as you suggested i won’t enable it.

1 Like