Whonix 255.255.255.255 --> windows vm doesn´t work

Hello,

after the qubes + windows vm 7 and 10 installation, doens´t the windows vm internet connection.

sys-whonix settings = netmask 255.255.255.255

sys-whonix settings: 10.137.0.8
netmask: 255.255.255.255
gateway 10.137.0.6
virtual dns: 10.139.1.1. and 10.139.1.2

windows vm settings = networking = sys whonix —> don´t have internet connection

winows 7 vm setting: 10.137.0.18
netmask: 255.255.255.255
gateway: 10.137.0.8
virtual dns: 10.139.1.1. and 10.139.1.2

when i change the windows vm settings = network = sys firewall or none --> i do have internet connection

can everybody help me ?

I am not sure but whonix only allow TCP I think…( that might be reason).

when I look at my old qubes system, the following is compared:

old qubes system: -> sys whonix
normal subnetmask
255.255.255.0

new qubes system: —> sys whonix subnetmask:
255.255.255.255

Yeah, try changing the netmask in Win box to 255.255.255.0

also, i have try
change network settings in windows vm manuell: doesn´t work with internet
if i change “automatic network adress” it will be the same data by manual

after then

i change “qube settings” on windows vm to “Network” to “default sys firewall”
–> now, internet connection is okay, with the same data 255.255.255.0 and also correct IP --> its the same data how i explain first of the text

now, i think, i “must” change the network settings of “sys-whonix” from 255.255.255.255 to 255.255.255.0 ??? --> in my old qubes system: “sys-whonix” has 255.255.255.0

thanks for your help

you stole my username :stuck_out_tongue:

here is something i said on reddit:

  1. if the distro has xen drivers installed but no qubes packages, you need to use manual ip config.

  2. if the distro doesnt have xen drivers installed you can use dhcp config.

  3. if you use dhcp config for the hvm since it does not have xen drivers, but you will connect to sys-whonix, you will need a new netvm(proxyvm) in between the hvm and sys-whonix

windows probly works because #2

ubuntu probly doesnt work because #1. ubuntu has xen drivers which disable emulated nics…and that breaks dhcp. you have to manually assign ips that qubes tells you to if you dont have the qubes networking packages


basicaly if you use a hvm that doesnt have xen (windows), you can use dhcp BUT you need another proxyvm in between if you want to connect to sys-whonix.

i havent figured out why yet. but when a hvm uses dhcp it always receives a def gateway of 10.137.0.1 from the dm domain. when it tried to do internet it looks for 10.137.0.1. qubes is configured that the netvm always responds with ‘hey im 10.137.0.1’ even when its not because they all have mac addr fe:ff:ff:…:ff. for some reason that doesnt work with sys-whonix directly. so you have to create another qube that provides net and is cofigure with sys-whonix for upstream.

…or just use manual config which tells windows who the real gw is (sys-whonix) so it doesnt have to ‘search’ for it with imagniary addresses like 10.137.0.1 (qubes never assigns a netvm this ip)

edit: qubes os likes to make qubes believe they are the only host on the network by assigning netmask 255.255.255.255. this is fine when you have a qube that has qubes pkgs. but for a hvm like windows, just give it a 24 bit 255.255.255.0 to keep stuff simple

Hello. I might be kind of late but… there is something I think it might help. I have read a page of Whonix website and it says to configure your network addresses as

IP address 10.152.152.50
Subnet netmask 255.255.192.0
Default gateway 10.152.152.10
Preferred DNS server 10.152.152.10

on Windows.
I think we should use some command on dom0 to change the Windows VM network addresses to the Whonix specifications, but
I don’t know how to change the VMs addresses on Qubes (and it looks like to not be available on GUI).