[qubes-users] Still not able to install rofi in dom0?

I was trying to install rofi earlier and ended up giving up hoping an update might change things? Well I just tried again and got a different error (before I was getting an error that was something like rofi not found i think). Now I am getting:

sudo qubes-dom0-update rofi
Using sys-whonix as UpdateVM to download updates for Dom0; this may take some time...
--> Running transaction check
---> Package rofi.x86_64 0:1.6.0-1.fc25 will be installed
--> Processing Dependency: rofi-themes = 1.6.0-1.fc25 for package: rofi-1.6.0-1.fc25.x86_64
--> Processing Dependency: libxkbcommon-x11.so.0(V_0.5.0)(64bit) for package: rofi-1.6.0-1.fc25.x86_64
--> Processing Dependency: libxcb-ewmh.so.2()(64bit) for package: rofi-1.6.0-1.fc25.x86_64
--> Processing Dependency: libxcb-icccm.so.4()(64bit) for package: rofi-1.6.0-1.fc25.x86_64
--> Processing Dependency: libxcb-xrm.so.0()(64bit) for package: rofi-1.6.0-1.fc25.x86_64
--> Processing Dependency: libxkbcommon-x11.so.0()(64bit) for package: rofi-1.6.0-1.fc25.x86_64
--> Running transaction check
---> Package libxkbcommon-x11.x86_64 0:0.7.1-1.fc25 will be installed
---> Package rofi-themes.noarch 0:1.6.0-1.fc25 will be installed
---> Package xcb-util-wm.x86_64 0:0.4.1-8.fc24 will be installed
---> Package xcb-util-xrm.x86_64 0:1.2-1.fc25 will be installed
--> Finished Dependency Resolution
rofi-1.6.0-1.fc25.x86_64.rpm | 196 kB 00:01
xcb-util-xrm-1.2-1.fc25.x86_64.rpm | 18 kB 00:00
xcb-util-wm-0.4.1-8.fc24.x86_64.rpm | 29 kB 00:00
libxkbcommon-x11-0.7.1-1.fc25.x86_64.rpm | 22 kB 00:00
rofi-themes-1.6.0-1.fc25.noarch.rpm | 19 kB 00:00
Successfully verified /var/lib/qubes/dom0-updates/packages/libxkbcommon-x11-0.7.1-1.fc25.x86_64.rpm
Successfully verified /var/lib/qubes/dom0-updates/packages/python3-xen-4.8.5-28.fc25.x86_64.rpm
Successfully verified /var/lib/qubes/dom0-updates/packages/qubes-gpg-split-dom0-2.0.50-1.fc25.x86_64.rpm
ERROR: could not verify /var/lib/qubes/dom0-updates/packages/rofi-1.6.0-1.fc25.x86_64.rpm
ERROR: could not verify /var/lib/qubes/dom0-updates/packages/rofi-themes-1.6.0-1.fc25.noarch.rpm
Successfully verified /var/lib/qubes/dom0-updates/packages/xcb-util-wm-0.4.1-8.fc24.x86_64.rpm
Successfully verified /var/lib/qubes/dom0-updates/packages/xcb-util-xrm-1.2-1.fc25.x86_64.rpm
Successfully verified /var/lib/qubes/dom0-updates/packages/xen-4.8.5-28.fc25.x86_64.rpm
Successfully verified /var/lib/qubes/dom0-updates/packages/xen-hvm-4.8.5-28.fc25.x86_64.rpm
Successfully verified /var/lib/qubes/dom0-updates/packages/xen-hypervisor-4.8.5-28.fc25.x86_64.rpm
Successfully verified /var/lib/qubes/dom0-updates/packages/xen-libs-4.8.5-28.fc25.x86_64.rpm
Successfully verified /var/lib/qubes/dom0-updates/packages/xen-licenses-4.8.5-28.fc25.x86_64.rpm
Successfully verified /var/lib/qubes/dom0-updates/packages/xen-runtime-4.8.5-28.fc25.x86_64.rpm
ERROR: could not verify one or more packages

Thoughts?

Alittle additional information, it seems that not only am i getting verification errors for rofi related packages but I also tried (just to see what would happen) installing other packages like:

sudo qubes-dom0-update --clean qvm-screenshot-tool
Using sys-whonix as UpdateVM to download updates for Dom0; this may take some time...
Cleaning repos: fedora qubes-contrib-dom0-r4.0-current qubes-dom0-current
               : qubes-templates-itl updates
Cleaning up Everything
fedora/metalink | 3.2 kB 00:00
fedora | 4.3 kB 00:00
fedora-32-minimal: command failed with code: 143 ] 242 kB/s | 4.4 MB 01:30 ETA
fedora/primary_db | 26 MB 01:47
qubes-contrib-dom0-r4.0-current | 3.0 kB 00:00
qubes-contrib-dom0-r4.0-current/primary_db | 16 kB 00:00
qubes-dom0-current/metalink | 2.7 kB 00:00
https://mirror.linux.pizza/qubes-os.org/repo/yum/r4.0/current/dom0/fc25/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
qubes-dom0-current | 3.8 kB 00:00
qubes-dom0-current/primary_db | 483 kB 00:02
qubes-templates-itl/metalink | 2.7 kB 00:00
qubes-templates-itl | 3.0 kB 00:00
qubes-templates-itl/primary_db | 6.9 kB 00:00
updates/metalink | 3.0 kB 00:00
updates | 4.7 kB 00:00
updates/primary_db | 12 MB 00:51
--> Running transaction check
---> Package qvm-screenshot-tool.x86_64 0:0.7-0.fc25 will be installed
--> Processing Dependency: scrot for package: qvm-screenshot-tool-0.7-0.fc25.x86_64
--> Running transaction check
---> Package scrot.x86_64 0:0.8-14.fc24 will be installed
--> Processing Dependency: libImlib2.so.1()(64bit) for package: scrot-0.8-14.fc24.x86_64
--> Processing Dependency: libgiblib.so.1()(64bit) for package: scrot-0.8-14.fc24.x86_64
--> Running transaction check
---> Package giblib.x86_64 0:1.2.4-24.fc24 will be installed
---> Package imlib2.x86_64 0:1.4.9-1.fc25 will be installed
--> Processing Dependency: libgif.so.4()(64bit) for package: imlib2-1.4.9-1.fc25.x86_64
--> Running transaction check
---> Package giflib.x86_64 0:4.1.6-15.fc24 will be installed
--> Finished Dependency Resolution
qvm-screenshot-tool-0.7-0.fc25.x86_64.rpm | 18 kB 00:00
imlib2-1.4.9-1.fc25.x86_64.rpm | 212 kB 00:00
giflib-4.1.6-15.fc24.x86_64.rpm | 44 kB 00:00
giblib-1.2.4-24.fc24.x86_64.rpm | 27 kB 00:00
scrot-0.8-14.fc24.x86_64.rpm | 25 kB 00:00
Successfully verified /var/lib/qubes/dom0-updates/packages/giblib-1.2.4-24.fc24.x86_64.rpm
Successfully verified /var/lib/qubes/dom0-updates/packages/giflib-4.1.6-15.fc24.x86_64.rpm
Successfully verified /var/lib/qubes/dom0-updates/packages/imlib2-1.4.9-1.fc25.x86_64.rpm
ERROR: could not verify /var/lib/qubes/dom0-updates/packages/qvm-screenshot-tool-0.7-0.fc25.x86_64.rpm
Successfully verified /var/lib/qubes/dom0-updates/packages/scrot-0.8-14.fc24.x86_64.rpm
ERROR: could not verify one or more packages

Well I got rofi installed, only because I happened upon a dated reddit post https://www.reddit.com/r/Qubes/comments/aap0zs/my_qubes_os_with_i3/ which referred readers to https://github.com/mohabaks/dotfiles/tree/master/config/Qubes-os which had a link to https://github.com/fepitre/qubes-rofi/issues/1#issuecomment-667303259

This solution was back in August 2020 but it worked for me, no clue why the method in the documentation did not work, havent been able to get any feedback but I am hoping this will help any others trying to install rofi.

Well I got rofi installed, only because I happened upon a dated reddit
post https://www.reddit.com/r/Qubes/comments/aap0zs/my_qubes_os_with_i3/
which referred readers to
https://github.com/mohabaks/dotfiles/tree/master/config/Qubes-os which
had a link to
https://github.com/fepitre/qubes-rofi/issues/1#issuecomment-667303259

This solution was back in August 2020 but it worked for me, no clue why
the method in the documentation did not work, havent been able to get
any feedback but I am hoping this will help any others trying to install
rofi.

Stumpy, dude, thank you for your perseverance! :wink:
Your findings combined with the official Qubes documentation solved it.
Apparently importing the contrib key is necessary for the install to succeed.

So after importing with:

sudo rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes-4-contrib-fedora

I just followed the documentation at https://www.qubes-os.org/doc/installing-contributed-packages/ and now the install went fine, finally!
After changing the i3 config file it all works flawlessly on 4.0. I preferred not to enable the testing repo but just keep the contrib, FWIW.
Also many thanks to fepitre!

Maybe it is wise to update the documentation, if this is indeed all correct? Or did we miss this somewhere?

I am (really) glad it helped someone, I posted again and again trying to figure what i was doing wrong.

It would indeed be wise to update the documentation as its seriously lacking for rofi at least (and I suspect for some other qubes contrib packages). I am not familiar with github but will see if I can edit or pull or whatever its called to edit the rofi (and maybe polybar) page.

I would not be surprised at all if I missed something else, so if you do pick some other nuggets please do reply to the group (i noticed the mailing list posts are automatically put in the discourse forum.