[qubes-users] Qubes boots to grey screen, mouse frozen

Aloha generous qubes-users group. I’ve been getting used to qubes for the past 6months or so and have found lots of helpful conversations in this group. Have had no problems with my thinkpad T580.

The issues arose when I first tried to update with the GUI. Fedora and qubes itself updated just fine but whonix came back with a failed update. I shutdown laptop and tried again. When I tried updating whonix that go around, the computer froze, i let it sit for 10minutes and then did a hard shutdown. After reboot, it will let me now put my password and disk pw in, but then boots to a grey screen and a frozen mouse. I would suspect from the attempt at starting the whonix VM.

Two questions:

  1. How do I enable debugging or logs so I can bring them here?
  2. Can I enable some sort of advanced startup options? Disable the startup of specific VMs?

TheCrispyToast:

Aloha generous qubes-users group. I've been getting used to qubes for the
past 6months or so and have found lots of helpful conversations in this
group. Have had no problems with my thinkpad T580.

The issues arose when I first tried to update with the GUI. Fedora and
qubes itself updated just fine but whonix came back with a failed update. I
shutdown laptop and tried again. When I tried updating whonix that go
around, the computer froze, i let it sit for 10minutes and then did a hard
shutdown. After reboot, it will let me now put my password and disk pw in,
but then boots to a grey screen and a frozen mouse. I would suspect from
the attempt at starting the whonix VM.

Two questions:
1. How do I enable debugging or logs so I can bring them here?
2. Can I enable some sort of advanced startup options? Disable the startup
of specific VMs?

This seems like it could be a hardware or disk corruption issue. Try hitting ctrl-alt-F5 to switch to a text terminal when you are at the grey screen. Should hopefully be able to login there and pull logs. If your disk was close to filling up, that could point more towards drive corruption.

My disk was definitley not close to filling up, but it may have been one of the VM partitions that was close to filling up. I have managed to get into the dom0 terminal upon bootup. Excuse my ignorance, but could you asssit with the proper commands for pulling logs and/or turning certain VMs off from startup? I think itd be better to start a boot with only dom0 running. As I said before, sometimes it will let me even get logged in and then once whonix appears to start the whole system freezes.

TheCrispyToast:

Was able to disable whonix from startup, that didn’t seem to do anything. That’s assuming I was supposed to restart after that and try to boot as normal right? Is there a way to then exit terminal and continue signing in with GUI?

I tried to disable firewall/net VM and then got a watchdog error, i’d imagine this is a security feature of qubes?

Sorry it’s a photo and not text!

Edit: I did some research and meant to edit this before I posted. Watchdog actually appears to be an NMI and I found one thread about someone increasing the threshold? I had thought this was a response error to when I tried to disable the firewall/net VM but actually might be an error of its own. Are my resources being hogged up somehow? I have made it past user account login twice now, both times it will let me move the mouse for a bit and then when i try to click on anything the whole system freezes.

If it’s any indicator, I can load debian just fine so I don’t think its anything hardware related. I must have tweaked with a setting in qubes I wasn’t supposed to.

TheCrispyToast:

Edit: I did some research and meant to edit this before I posted. Watchdog
actually appears to be an NMI and I found one thread about someone
increasing the threshold? I had thought this was a response error to when I
tried to disable the firewall/net VM but actually might be an error of its
own. Are my resources being hogged up somehow? I have made it past user
account login twice now, both times it will let me move the mouse for a bit
and then when i try to click on anything the whole system freezes.

If it's any indicator, I can load debian just fine so I don't think its
anything hardware related. I must have tweaked with a setting in qubes I
wasn't supposed to.

Yes, that CPU lockup is causing your troubles. It's often caused by a misbehaving hardware device. Have you added any recently, or upgraded the kernel? Since it's related to your mouse movement, any USB devices? You can try the previous kernel by changing it per Installing and updating software in dom0 | Qubes OS.

Was able to disable whonix from startup, that didn't seem to do anything. That's assuming I was supposed to restart after that and try to boot as normal right? Is there a way to then exit terminal and continue signing in with GUI?

I tried to disable firewall/net VM and then got a watchdog error, i'd imagine this is a security feature of qubes?

For me it looks like some kind of hardware problem.