[qubes-users] HCL -- Intel NUC10i7 issues with kernel-latest

5.9.14 does not make it to X11 (empty screen with cursor). 5.8.16 works just fine.

Yeah,

I think I’m having the same issue - I do see the login screen, but the upper half of the screen is just black. Switching to console and back fixes that and I can log in, but then there’ are random glitches on parts of the screen/windows, etc. Disabling compositor mostly fixed that, but not 100%.

How did you install the 5.8.16 kernel? When I do something like

$ qubes-dom0-update kernel-lateat-5.8.16

it shows me the package, downloads it, but then it tells me “no package kernel-latest-5.8.16 available” so I’m a bit confused.

I’m currently running on 4.19.155 which works, but I’m not sure it fully supports the new CPU in the laptop (mainly the power management).

regards

tv.f...@gmail.com:

How did you install the 5.8.16 kernel? When I do something like

$ qubes-dom0-update kernel-lateat-5.8.16

it shows me the package, downloads it, but then it tells me "no package
kernel-latest-5.8.16 available" so I'm a bit confused.

See https://www.qubes-os.org/doc/software-update-dom0/#kernel-upgrade. Should be something like "sudo qubes-dom0-update kernel-latest". Might also want kernel-latest-qubes-vm.

EXAMPLE:

sudo qubes-dom0-update kernel-latest-1000:5.9.14-1.qubes.x86_64
--enablerepo=qubes-dom0-unstable

simply change numbers to your wanted kernel version.

if you only have the main qubes repo enabled, running qubes-dom0-update kernel-latest should install v5.8.16. 5.9 and upcoming 5.10 builds can be found in current-testing, though the latter has yet to land.