[qubes-users] HCL - Dell XPS 9310 2-in-1

I found it very difficult to get Qubes installed and useable. These are some notes I made at the time and may need some adjustment for other scenarios.

INSTALLATION 4.04rc2:

Use 8GB USB stick (left OR right side works). Bigger sizes failed for me.

disable Secure Boot

enable ACHI

edit sda2 EFI/BOOT/BOOTX64.cfg

comment out under ‘qubes-verbose’ section

noexitboot=1

mapbs=1

text install with ‘inst.text’ placed before i915 in the following line:

kernel=vmlinuz inst.stage2=hd:LABEL=Qubes-R4.0-x86_64 i915.alpha_support=1

make sure networking is attached to bring up GUI

I had to combine sys-net and sys-usb in the install options because I was using a docking station for ethernet.

Disable power mgmt except blank screen in Screensaver

Touchpad settings: enable tap and adjust speed

sudo qubes-dom0-update kernel-latest-qubes-vm

sudo qubes-dom0-update kernel-latest

(remove old kernel in qubes EFI)

sudo qubes-dom0-update --action=[reinstall|remove|list] kernel-latest[-qubes-vm]

sudo dnf remove qubes-template-fedora-32

A lot of video issues causing crashes. Found the following fixed it enough so far to make it useable:

https://github.com/Qubes-Community/Contents/blob/master/docs/troubleshooting/intel-igfx-troubleshooting.m

change: i915.alpha_support=1 → i915.force_probe=*

The following are some miscellaneous notes to get the DPI and GTK working right. I never tuned this properly, so you will have to play around. Please post configurations if you ever get this correct.

DPI 288 & Font size adjust to 6 in Appearance settings

Window Manager - xhdpi

  • about:config in Firefox and search for layout.css.devPixelsPerPx set this value to 2 or 1.5 as you wish to adjust the size of the Firefox icons

  • https://askubuntu.com/questions/652021/adapt-font-and-icon-sizes-to-high-definition-screen-resolutions-in-ubuntu-studio

      1. Set a Custom DPI setting
    • Open a terminal with CTRL+ALT+t and enter

      • LANG=c xfce4-settings-manager
    • In “Appearence”->Fonts-> “Custom DPI Setting:” set this to 288 (instead of the default 96).

    • Log off and on again to accept the new settings in all windows.

      1. Adapt Theme and settings
      • Set your panel size to a height of 48

      • In xfce4-settings-manager->“Settings Editor” (xfce4-settings-editor)

        - in section xfce4-desktop (create an entry if it doesn't exist)
        
    • desktop-icons/icon-size Type Integer and set it to 128

      • in section xsettings set CursorThemeSize to 48

      • in section xsettings set Gtk/IconSizes to

    • gtk-large-toolbar=32,32:gtk-small-toolbar=24,24:gtk-menu=32,32:gtk-dialog=88,88:gtk-button=32,32:gtk-dnd=32,32

    • Or use the commandline:

    • xfconf-query -c xsettings -p /Gtk/IconSizes -s “gtk-large-toolbar=32,32:gtk-small-toolbar=24,24:gtk-menu=32,32:gtk-dialog=88,88:gtk-button=32,32:gtk-dnd=32,32”

      • gtk-large-toolbar are main toolbars

      • gtk-small-toolbar are secondary toolbars

      • gtk-menu are menus

      • gtk-dialog are dialog icons

      • gtk-button are buttons (eg the xfce panel uses buttons)

      • gtk-dnd are the icons displayed if you drag and drop a file or a folder

    • you can change them to any size as long your icon theme supports it

      • In xfce4-settings-manager->“Window Manager”

        - select the theme Default-xhdpi (since Xfce 4.12 - [upgrade instructions for 14.04](http://ubuntuportal.com/2015/03/how-to-upgrade-xfce-4-10-to-xfce-4-12-in-xubuntu-14-04-and-xubuntu-14-10.html))
        
        - Set the Title Font to 12
        
      • Download the Widepanel Appearance ** in xfce4-settings-manager->“Appearance” select Widepanel

      • In the File Manager thunar adapt the preferences:

        - Set Iconsize in the sidepanel to "small" or "normal"
        

xfce4-display-settings command.

display resolution 3840x2400 in .config/xfce4/xfconf/xfce-perchannel-xml/displays.xml

Qubes-HCL-Dell_Inc_-XPS_13_9310_2_in_1-20210328-191641.yml (735 Bytes)

Hi turscar,

thank you for your HCL report, it is now part of this pull request:

... and will be visible on the website soon!

You wrote:

I found it very difficult to get Qubes installed and useable.

It sounds like most of your trouble is with the integrated graphics (Iris Xe), which is not too surprising as your laptop is very new. The support for Tiger Lake will likely get better over time as dom0 gets a fresher Fedora version or additional updates.

The following are some miscellaneous notes to get the DPI and GTK
working right. I never tuned this properly, so you will have to play
around. Please post configurations if you ever get this correct.

I spend months struggling with HiDPI and the solution that works best for me is surprisingly simple:

-> remove gnome-settings-daemon from your template(s) or use minimal
    templates that don't have it from the start

-> in your template add to /etc/X11/Xresources (Fedora) or
    /etc/X11/Xresources/x11-common (Debian) the following line:

  Xft.dpi: 288

(In dom0 leave the /etc/X11/Xresources alone and just set the DPI in the XFCE settings)

/Sven

1 Like

Sven

I just saw your reply. Finally, something that works. I settled on this configuration, in case it helps anyone else. Thank you very much.

→ remove gnome-settings-daemon from template(s)/some dependencies removed also
→ in templates add:
/etc/X11/Xresources (Fedora/Dom0) Xft.dpi: 192
/etc/X11/Xresources/x11-common (Debian/Whonix WS+GW) Xft.dpi: 192
XFCE-settings in Appearance to DPI 192 / font 11
All Terminals ->Prefs->enable Custom Font–>set 11
Window Manager - xhdpi + Title font = 11
Settings Editor->xsettings->create “IconSizes” and set ‘gtk-menu=32,32’

1 Like