[qubes-users] Disable lock screen / screenshot question

How do you disable the automatic screen lock? I have the screensaver disabled and the lock screen option unchecked but it still locks after a few minutes.

Also when using the screenshot function in system tools, is it possible to save to the AppVM file system you are currently using rather than to Dom0? Or how do I access it once it is saved to Dom0?

How do you disable the automatic screen lock? I have the screensaver
disabled and the lock screen option unchecked but it still locks after a
few minutes.

For me, there is a "presentation mode" on the battery icon (which shows
on both desktop and laptop) that disables the screen lock.

Also when using the screenshot function in system tools, is it possible to
save to the AppVM file system you are currently using rather than to Dom0?
Or how do I access it once it is saved to Dom0?

You should be able to get them to your AppVM using `qvm-copy-to-vm <vm

Better: create in dom0 a file containing:

#!/bin/bash
qvm-copy-to-vm \(zenity \-\-entry \-\-title=&#39;Send to VM&#39; \-\-text=&#39;Destination VM&#39;\) &quot;{BASH_ARGV[@]}"

Save that as an executable script, such as "~/.local/bin/send-to-vm.sh".
Then, open dom0 file manager, right click any png, click open with other
application, and under "use a custom command" enter "send-to-vm.sh %s".
This "registers" the script in the application list.

Then, when you take a screenshot, instead of choosing "save", choose
"open with..." and see if your script shows up in the list of available
applications. If still not, you might have to write a simple .desktop
file in ~/.local/share/applications in order for it to show
up as an option.

How do you disable the automatic screen lock? I have the screensaver
disabled and the lock screen option unchecked but it still locks after a
few minutes.

For me, there is a "presentation mode" on the battery icon (which shows
on both desktop and laptop) that disables the screen lock.

Also when using the screenshot function in system tools, is it possible to
save to the AppVM file system you are currently using rather than to Dom0?
Or how do I access it once it is saved to Dom0?

You should be able to get them to your AppVM using `qvm-copy-to-vm <vm
> <filename>` from the terminal.

Better: create in dom0 a file containing:

#!/bin/bash
qvm-copy-to-vm \(zenity \-\-entry \-\-title=&#39;Send to VM&#39; \-\-text=&#39;Destination VM&#39;\) &quot;{BASH_ARGV[@]}"

Save that as an executable script, such as "~/.local/bin/send-to-vm.sh".
Then, open dom0 file manager, right click any png, click open with other
application, and under "use a custom command" enter "send-to-vm.sh %s".

When trying, it seems my Dom0 does not have a file manager in the menu. I had to run "thunar" manually from the terminal.

Also: Wouldn't qvm-move-to-vm be preferrable (also replacing "Send" with "Move")?

Better: create in dom0 a file containing:

#!/bin/bash
qvm-copy-to-vm \(zenity \-\-entry \-\-title=&#39;Send to VM&#39; \-\-text=&#39;Destination VM&#39;\) &quot;{BASH_ARGV[@]}"

Save that as an executable script, such as "~/.local/bin/send-to-vm.sh".
Then, open dom0 file manager, right click any png, click open with other
application, and under "use a custom command" enter "send-to-vm.sh %s".

When trying, it seems my Dom0 does not have a file manager in the menu.
I had to run "thunar" manually from the terminal.

you are right.

Also: Wouldn't qvm-move-to-vm be preferrable (also replacing "Send" with
"Move")?

you are right again. It was a "proof of concept" code. Thank you for the
correction!

This "registers" the script in the application list.

Then, when you take a screenshot, instead of choosing "save", choose
"open with..." and see if your script shows up in the list of available
applications. If still not, you might have to write a simple .desktop
file in ~/.local/share/applications in order for it to show
up as an option.

Or write it by hand: like
  ~/.local/share/applications/userapp-screenshot.desktop containing

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
NoDisplay=true
Exec=/home/user/.local/bin/send-to-vm.sh %f
Name=Send a screenshot to VM
Comment=Custom definition for SCREENSHOT.sh

cheers

This is by design. Using a file manager in dom0 is a security risk and is therefore discouraged:

[...]
When trying, it seems my Dom0 does not have a file manager in the menu. I had to run "thunar" manually from the terminal.

This is by design. Using a file manager in dom0 is a security risk and is therefore discouraged:

https://github.com/Qubes-Community/Contents/blob/master/docs/security/security-guidelines.md#dom0-precautions

So is there an alternative that gets the user script registered for saving a screenshot?

I'm not sure exactly what you mean, but there's:

[...]
When trying, it seems my Dom0 does not have a file manager in the menu. I had to run "thunar" manually from the terminal.

This is by design. Using a file manager in dom0 is a security risk and is therefore discouraged:

https://github.com/Qubes-Community/Contents/blob/master/docs/security/security-guidelines.md#dom0-precautions

So is there an alternative that gets the user script registered for saving a screenshot?

I'm not sure exactly what you mean, but there's:

I mean: It seems you need the file manager to open the file just to register it as handler; is there an alternative not using the file manager?

https://github.com/QubesOS/qubes-issues/issues/953

Unfortunately the issue is quite long, and you are not referring to a specific comment...

I'm not sure exactly what you mean, but there's:

I mean: It seems you need the file manager to open the file just to
register it as handler; is there an alternative not using the file manager?

not that I know. But you can register it "by hand" by creating a .dsktop
file yourself (as I explained earlier). Put these lines

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
NoDisplay=true
Exec=/home/user/.local/bin/send-to-vm.sh %f
Name=Send a screenshot to VM
Comment=Custom definition for send-to-vm.sh

in a new file in ~/.local/share/applications/userapp-screenshot.desktop

– You received this message because you are subscribed to the Google Groups “qubes-users” group. To unsubscribe from this group and stop receiving emails from it, send an email to . To view this discussion on the web visit .