KDE - changing the way you use Qubes

I think KDE is a great match for Qubes, and makes the whole user
experience better.

KDE has a simple menu editor, that helps you to focus on the important
things - grouping qubes, ordering shortcuts, and so on.
There are simple tools to control (and master) many windows from
multiple qubes, and to quickly get to the window you want.

You can also use Activities - a way of making each desktop a separate
workspace, with its own wallpaper, widgets and launchers.
You can force windows from particular qubes to appear in distinct
activities. This helps to keep qubes separate as you want, and reduces
the risk of transferring data between the wrong qubes.

KDE is easy to control from the keyboard, and almost every aspect of
Qubes use can be dealt with, or automated.

I think that I can attach images to this email, and they will appear.
Maybe I can craft an HTML email by hand?
In the meantime, here (I hope) is a screenshot of a KDE menu, and two activities,
showing distinct wallpaper, widgets and launchers.

There are more images, and something like a basic guide with many screenshots,
over at GitHub - unman/kde

You can install KDE in 4.0 with sudo qubes-dom-update @kde-desktop-qubes
It will change the way you use Qubes.

If you have questions, problems, or tips about using KDE, post them here.

5 Likes

Really great share @unman. I’ll try soon I especially like the idea of one-domain-per-workspace along with corresponding desktop icons and wallpaper.

They arrived perfectly. Also, if your add attachments they should also arrive here (except for things like gpg signatures and other meta stuff).

1 Like

Nice! I’m also going to try it.
While using xfce I also like to use one domain per workspace, but I think KDE is going to be better for this.

Well it’s time to say “shut up and take my request” for the Qubes repositories.

Ah, btw, how do you put the personal-Firefox and personal-Files on the desktop? This is going to be great for organizing my VMs.

some icons and configurations are broken see:

on this first image you can see that the “networkmanager” icon from systemtraysettings are invisible but when we put the mousecursor it shows the label information, another problem is the sys-whonix icon a little bit weird, like noquality.

on the “APPLICATION MENU” using the “alternative” application Menu(a launcher based on cascading popup menus) we see that the icons that was suppposed to appear before the submenu text disappeared.

but when we setup the application menu with the “application menu launcher” alternative(right click on Q → alternative) the icons appears again.

noicon5
All the lockicons from q-domains menu is missed too

The absence of the Network Manager icon is a long standing issue - I’ve
tried to get some KDE developers onboard, but as yet with no success.
After a while, you just know where the icon should be from its absence.
(There are horrible hacks to make the icon appear - I think that the
screenshots I posted showed this: I don’t use them.)

I don’t use Whonix and cant see that image. If it’s weird I suspect that
the icons are not provided in scalable format. It’s an issue for Whonix.

The cascading menu doesn’t have icons - nothing is broken,that’s the
way it is.

I rarely use the q-domains menu, but nor has anyone reported this to me,
so I suspect in use it isn’t that important. I’ll see if there is an
obvious explanation.

There’s another KDE artefact - Top Right is a control field, but it gets
overlaid with a black square for each of the icons in the control
panel - disk, clipboard, devices etc. Use them once, and the square goes.

1 Like

I should have said, that Menu doesn’t have icons at the top level -
submenus do have icons, for qubes, folders, and applications.

1 Like

I had previously followed these instructions to install and subsequently uninstall KDE using these commands:

sudo qubes-dom0-update @kde-desktop-qubes
&
sudo dnf remove kdelibs plasma-workspace

In which case if one tries to install KDE again, it will fail with the message that the ‘KDE’ group is already installed. Simply reinstalling kdelibs and plasma-workspace leaves KDE in a weird and incomplete state (e.g. no taskbar).

There might be an elegant way to solve this that I do not know. However, here is how I solved it in R4.0.4 with success based on this post:

sudo qubes-dom0-update apper breeze-icon-theme colord-kde dolphin kcm_systemd kde-runtime kde-settings-pulseaudio kde-style-breeze kdelibs kdeplasma-addons kdialog khelpcenter khotkeys kinfocenter kmenuedit kmix konsole5 kscreen ksysguard kwin phonon-qt5-backend-gstreamer plasma-breeze plasma-desktop plasma-desktop-doc plasma-pa plasma-user-manager plasma-workspace polkit-kde qt5-qdbusviewer sddm sddm-breeze sddm-kcm sni-qt

…followed by the exact same command using the --action=reinstall parameter. Funny enough, this did not only reinstall KDE but also made features (like HiDPI in SSDM) work that I previously failed to get working.

This is exactly what I’ve been in need of, thank you very much! Adding this to the list of to-do’s. I love boxes inside boxes inside boxes, and I had truly started to go about this in a much more difficult way. Such fun awaits!