Intel NUC Support - Frost Canyon

Hi,

I just bought a 10th Generation Intel Core i7-10710U, partly because it seems to have reasonable support for Linux. I’ve got Ubuntu up and running no problem, but can’t get Qubes installed.

Are there known problems with this hardware? There are issues with some video cards, but don’t think the one listed here https://ark.intel.com/content/www/us/en/ark/products/196448/intel-core-i7-10710u-processor-12m-cache-up-to-4-70-ghz.html

Hi @mgifford,

Qubes OS works on NUC10, I daily use a NUC10i7FNK with the same CPU as you.

I don’t know for the specific Frost Canyon, but see my NUC10i7FNK HCL post from mail-archive or google groups, and also the Q/A in the qubes-user mailing-list thread.

That’s terrific news! Did you have any trouble with the installation? I can’t get the installation GUI to show up on the page. It stalls as I’ve defined here: https://github.com/QubesOS/qubes-issues/issues/6104

Terrible screenshots… but I can’t seem to get to get passed it.

My first (stupid) issue was a buggy 4GB USB stick, I switched to a newer and bigger one for the QubesOS 4.0 ISO.

My second and more important issue was the unrecognized network ethernet card. But I used an USB-ethernet adapter for the Qubes-OS installation. Then I updated to a latest kernel (5.6.16) which recognized my ethernet card. Then all rocks :smiley:

Verify the BIOS settings, I think it’s the main problem for you. See my HCL mailing-list post and also the question/answer from/to zhao in my HCL thread.

Are you using a very specific NUC10 or a very common like mine (NUC10i7FNK)? Check the differences between mine and yours.

Thanks @ludovic I’ve got a NUC10i7FNH1 so pretty much identical I think.

I’ve been trying two different USB sticks. Neither of them seem to be working.

I don’t know what changes should be made to the BIOS. Where is the HCL mailing list you are referring to? Can you send me a link?

I’m not sure how to update the kernel here.

I posted the links in my first post on this thread, I give them again:

My first post on the mailing list explained it (‘qubes-dom0-update kernel-latest’) like the Qubes-OS documentation (kernel upgrade).

But like I didn’t get the errors shown on your camera shots, I think that your BIOS settings is the main problem.
Please read first all this thread (BIOS settings I explained, zhaojx88 questions and my answers). Then if not resolved, ask specific questions here, I will help you.

Ok, I got an external USB NIC that I ordered to test this out.

I had to scroll down to your comment in the thread on July 26th where you outlined what needed to be done to the bios.

I had a lot of trouble getting to the Legacy Boot mode, but finally got there with this https://community.intel.com/t5/Intel-NUCs/NUC10-can-t-enable-Legacy-Boot/td-p/602288

Certainly wasn’t obvious.

With that I was able to get to the Qubes OS install. Still seemed pretty rough. I had installed Kubuntu on the NUC’s drive, but will install a bootable Linux USB & just format that.

Anyways, with the BIOS instructions (that I’d missed before), it looks like I am making progress.

Ok, I’m having trouble now getting network access through the external USB network device to access the USB NIC.

$ sudo qvm-usb

gives me “BACKEND:DEVID DESCRIPTION USED BY” but nothing else.

I’ve tried to skip ahead to

$ sudo qvm-usb attach sys-net sys-usb:3.3

But that gives me the error of. “qvm-usb: error: no backed vm ‘sys-usb’”. I think that’s because I’m not scanning available USB devices properly…

I assume that I do this right from the terminal of dom0 when it first boots up. This isn’t something to run from the Qube Manager, right?

@mgifford
After added the sys-usb VM, below my own archived tutorial for using a USB NIC.

For using a USB NIC:

  1. sys-net/Qube setting : remove all the devices
  2. sys-net/Start
  3. dom0/Terminal: qvm-usb for finding the USB NIC, ex: sys-usb:3.3
  4. dom0/Terminal: qvm-usb attach sys-net sys-usb:3.3
  5. sys-net/Terminal : ‘usb-devices’ display the USB devices of the VM
  6. sys-net/Terminal : ‘ip a’ display the network interface and the current IP
    => sys-net notifies that a new connection is activated, the red network icon displayed in the tray bar

On next boots, with Qubes Devices, set the USB NIC to sys-net. (I noted this in my tutorial but I don’t remember why, so useless or useful you will see)…

If this works for you, the next steps are:

  • update dom0
  • install the kernel-latest
  • sys-net set to using the kernel-latest (Qube settings, Advanced, kernel)
  • set sys-net to use the now detected NUC internal Ethernet card (driver e1000e) : device 00:1f.6 and set the ‘no-strict reset’ option

Good luck :wink: