install qubes-core-agent makes HVM not boot

Hi,

Apart from the normal Qubes usages of the different templates, I am also using a Debian 10 HVM which is LVM and Encrypted.
As sometimes I need to copy-paste data from and to it, I tried to figure out how I could use parts from the Debian templates in this HVM so I could just use the menu when right clicking on a file and selecting Copy or Move to another VM.
Luckily I made a clone from my HVM first before tampering with it. But I’ve also tried below steps with a fresh Debian 10.6.0 install. I’ve also tried different setups like normal, LVM and LVM+encrypted, but they all gave the same issue.

Steps I followed:

  • Copied the /etc/apt/qubes-r4.list from the Qubes Debian template to the HVM.
  • Added Qubes signing keys to the HVM.
  • Terminal ‘sudo apt install qubes-core-agent’ installed a bunch of things (see below pastebin).
    (and I also tried ‘sudo apt install qubes-vm-recommended’ with the same result)
  • Reboot.

During reboot it gives error:
[FAILED] Failed to start djust root filesystem size.
Then a few green [OK] lines
but then hangs a while on
[*** ] A start job is running for /dev/xvdc1
and when it can’t start that, it jumps to ‘tty1’

I have even tried above with a fresh Fedora 32 install with qubes-r4.repo from the Fedora template.
And for the sake of testing, I’ve even tried with a fresh Ubuntu and Unman’s repo and keys from https://qubes.3isec.org/ but both to no avail.

I’ve copied the install log from Debian Terminal to pastebin:


And in there I can see some errors, but I don’t know enough from Linux to know how to solve those issues.

I must be doing something structuraly wrong as it fails on 3 different distro’s. But apparently I can’t see the wood for the trees anymore and would appreciate some help or directions.

Thank you in advance