I3-gaps installed but not working when login

im trying to install i3 on qubesr4 using the steps from qubes user documentation

sudo qubes-dom0-update --clean i3 --allowerasing

but i get this message

Error: nothing provides dmenu needed by i3-1000:4.16-9.fc25.x86_64