HCL — Lenovo ThinkBook 14 G2 ARE (4.1)

Installing

Everything works (!!) using Qubes 4.1 20210424 from here: QubesOS 4.1 (alpha) Signed Weekly Builds.
BIOS options: Legacy support, UEFI first, Fast Boot & Secure Boot off, PSP off, OS Optimize Defaults off. No other changes to grub or other configs, no errors (yet) installing or booting. I used a 16 GB SanDisk USB 3.0 stick and the ISO loaded from Win10 using Rufus.

Remarks

It’s beautiful. Running super smoothly right now, even with only 8 GB RAM (I have a 16 GB SODIMM on the way — maxing out at about ~4 concurrent AppVMs)

Issues

In “Session and Startup > General > Logout Settings”, uncheck “Prompt on logout”. I found that clicking it would result in a lound, annoying error beep no matter what the volume settings were.

Attaching a USB to a TemplateVM/AppVM works well, though attaching just the USB’s corresponding block devices & individual partitions wasn’t working properly for me, but I didn’t investigate too closely.

Sometimes using sys-whonix for dom0 updates doesn’t work but sys-firewall still connects (potentially unrelated to Qubes).

Haven’t yet tried suspend or hibernate, as those didn’t work while on 4.0.4

4.0.4

Not recommended. Will boot & install with legacy support enabled, but updating the kernel past 5.4 (in both current and current-testing) kept breaking it with a freeze on boot, requiring a Fedora live USB to mount the EFI partition and change the default kernel back to 5.4 in xen.cfg.

Attachments

Qubes-HCL-LENOVO-20VF-20210425-183900.yml (855 Bytes)
Qubes-HCL-LENOVO-20VF-20210425-183900.cpiogz (10.4 KB) (need to rename to ‘cpio.gz’)

1 Like

Hi @hokieboat,

welcome to Qubes OS world :slight_smile:

For getting documentation/information/support, see :

Remember that 4.1 is alpha, so see the 4.1 forum section, and dedicated issues.

Thanks for this HCL, ThinkBook are common, your HCL will be useful for other users.

Check the issue reports if this problem already known…

I attache the USB device for all my usage, I never see a usage for a partition only…

1 Like

Thanks for the report @hokieboat and @ludovic for the warm welcome.

@Sven how are you handling 4.1 HCL reports? This is the first one I’ve seen.

@deeplow same way I handle all others. This is far from the first one for R4.1. I was offline the entire last week and will work my way through everything I’ve missed in the next 2 days. After that my response time should be back to normal.

1 Like

@hokieboat thank you for your HCL report, it is now part of this pull
request:

… and will be visible on the website soon!

1 Like