[HCL] ASUS Transformer book TP500LAB

Introduction

I don’t want to be connected howsoever with google, so I decided to post HCL of my laptop here instead of signing to the mailing list.

This is TP500LAB, not TP500LA or TP500LN

Question

Could you explain me for what are the fields: cpu-short, chipset-short, gpu-short.

HCL

---
layout:
  'hcl'
type:
  'notebook'
hvm:
  'yes'
iommu:
  'yes'
slat:
  'yes'
tpm:
  'unknown'
remap:
  'yes'
brand: |
  ASUSTeK COMPUTER INC.
model: |
  TP500LAB
bios: |
  TP500LAB.204
cpu: |
  Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz
cpu-short: |
  FIXME
chipset: |
  Intel Corporation Broadwell-U Host Bridge -OPI [8086:1604] (rev 09)
chipset-short: |
  FIXME
gpu: |
  Intel Corporation HD Graphics 5500 [8086:1616] (rev 09) (prog-if 00 [VGA controller])
gpu-short: |
  FIXME
network: |
  Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)
  Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter
memory: |
  11963
scsi: |
  ADATA SU900      Rev: 5A  
usb: |
  1
versions:

- works:
    yes
  qubes: |
    R4.0
  xen: |
    4.8.5-19.fc25
  kernel: |
    4.19.132-1
  remark: |
    xscreensaver set screen to black instead of power off it. PCI issue similar to https://www.ubuntupit.com/best-xfce-themes-for-linux/. It's fixable. You need to create a daemon, like in mentioned thread where the address of device is: 0000:02:00.0 (it's inbuilt realtek card reader, obviously not working on Linux even on windows it needs drivers). I do not use touchscreen but I see it needs special workaround. I don't use the newest UEFI but in there there is no TPM option, so I think it should be changed from "Unknown" to "NO" state. 
  credit: |
    BBro
  link: |
    https://github.com/QubesOS/qubes-issues/issues/1393

---

Remark (copy from HCL)

xscreensaver set screen to black instead of power off it. PCI issue similar to https://www.ubuntupit.com/best-xfce-themes-for-linux/. It’s fixable. You need to create a daemon, like in mentioned thread where the address of device is: 0000:02:00.0 (it’s inbuilt realtek card reader, obviously not working on Linux even on windows it needs drivers). I do not use touchscreen but I see it needs special workaround. I don’t use the newest UEFI but in there there is no TPM option, so I think it should be changed from “Unknown” to “NO” state.

Other Information

I changed in this laptop:

  • ram (upgraded from 8gb to 12gb witch is the maximum value because of second RAM part is soldered to the motherboard)
  • wireless card so it’s unofficial part, also I haven’t been testing it yet.
  • Disc to SSD
  • I destroyed somehow inbuilt speakers, don’t ask how… so I took them out.

Thanks for maintaining Qubes OS, you are the best! :slight_smile:

1 Like

Thank you for the report! I understand your concerns regarding Google. Unfortunately, our current system for updating the HCL involves a person gathering these reports from qubes-users, and I’m not sure if they’d be willing to also start checking here. However, if you’re up to it, you can always submit your report directly to the HCL repo as a pull request: https://github.com/QubesOS/qubes-hcl/tree/master

1 Like

I guess I’m that person, though still back-logged…

(Checking both places is no problem for me as long as the attachments
continue to come through without logging in to Google.)

3 Likes

Indeed you are. :heart:

If you like, we could try to see if anyone else is willing to take the baton for a while.

Ok, sounds good.

1 Like

I just tested and here on the forum, the attachments don’t get sent to the email, but by opening the email you have a link to download them. Would that be fine @tasket?

Here’s an example (not related to the OP’s):

Dell_Inc_-XPS_8920-20180228-144337.yml (1.1 KB)

1 Like

@deeplow Thank You :slight_smile: I’ll try

Now I see that I made bad remark, here’s corrected one:

xscreensaver sets screen to black instead of power off it. PCI issue similar to the previous one findable on github. You need to create a daemon, where the address of device is: 0000:02:00.0 (inbuilt realtek card reader)

The link pasted into remark should be:


(Then I was learning qubes and forgot to CTRL+SHIFT+V) :wink: