Dark mode in Debian 10 VM

I have installed tweaks in my template to change appearance to dark mode. I can change it in the template or in the vm but change do not take effect.

Have you read the following (community) documentation? On step 5. there are instructions that you specifically need to do on Debian.

3 Likes

ok thanx a lot
sorry for the inconvenience
sometimes I forget the good practices…

1 Like

Hello!

If i enabled dark mode on the debian-10 Template VM (works just fine, at least gnome terminal and gnome-tweaks are dark) and i’ve created a disposable VM based on this Template VM, shouldn’t need to be dark the Disposable VM too? Because it isn’t. I’ve checked the ~/.config folder of the disposable VM and there is no gtk-3.0 or gtk-4.0 folder. Am i missing something?

Thanks!

There are three VMs involved:

  1. templatevm (e.g. debian-10)

  2. appvm based on templatevm that itself is the dispvm template (has
    tempalte_for_dispvms=true)

  3. the dispvm (based on the appvm)

Changes you make in the home directory of 1) will not reflect in 2) by
design. All changes you make in the home directory of 2) will reflect in 3)

/Sven

2 Likes

Thanks! I thought if i make changes in the Template VMs those changes will reflect in all VMs based on the Template VM. Now evrething work fine! Strange, but i thought because i made changes in directories under the home folder (~/.config) i can make it without using sudo, but it needed the sudo privilege. Just a note, if somebody’s intrested why the changes are not accepted

Strange, but i thought because i made changes in directories under
the home folder (~/.config) i can make it without using sudo, but it
needed the sudo privilege.

You probably has sudo privileges (by mistake?) when creating that file
originally.

sudo chmod u+rw ~/.config/the_file should fix it

1 Like

Thanks! I think i made the settings.ini file by accident with sudo privilege. Now everythings work fine.