Copy file without encryption

Hello, I want to use Qubes as a connection to the Internet and share the information with a stick. Have no experience with Linux or Qubes, but feel it is understandable. When I send files with firefox in sys-firewall or copy received files to a stick they can not be read by a program in windows. What do I have to do so that the files are saved or sent unencrypted on a stick?
Yes, this is not the safest way, but I’m not further.

I am not sure what you mean here. Do you want to use the standard Internet connection? Then you can use it in any VM which is connected to sys-firewall. You should not use sys-firewall itself for that. You also should not run anything in it.

Do you want to use a usb-stick? For that you can connect your inserted stick into any VM by using Qubes Devices in the system tray. Again, you should not use sys-firewal for that.

I don’t understand what you are trying to do. Could you be more specific? Firefox cannot send files between VMs in Qubes OS, neither it should be able to. For that we have Copying and moving files between qubes | Qubes OS.

Qubes OS is a very different system compared with Windows, Linux or Mac. It is very helpful to read the documentation in order to understand how it is designed and why. Otherwise you will not get any benefit from using it and instead just put yourself into unnecessary trouble with UX.

Hello @Lozi,

I am also not sure what you mean, but let me try to interpret it and you can tell me if I am understanding you: You want to understand whether the files you send over the Internet through Firefox or the files you transfer to a USB stick are encrypted. You think this may be the case because Windows does not recognize the files, or perhaps does not even recognize the USB, when you try to view the ones you transferred to your USB stick. Is that correct?

If so, then I think many misunderstandings are happening here, much of which has to do with conflating the layers involved and being unfamiliar with the underlying technologies. Linux and Qubes OS do not, by default, encrypt each file you have such that they cannot be viewable on any other machine even when unlocked and transferred to it. While Linux and Qubes OS can be encrypted at an operating system level, this only means that the data and operating system are not locally accessible unless you unlock them. Once you have them unlocked, such as by typing in your LUKS passphrase during boot, the entire operating system and all files not otherwise encrypted are accessible in plaintext, meaning they are plainly accessible when decrypted but not to those who are unable to decrypt them. Any files you copy from your operating system while unlocked will not remain encrypted unless you encrypt them some other way or only transfer them to another device that it also encrypted. This is the default behavior.

Firefox does not change this, and any transport encryption it may do only encrypts the files in transit (while zipping over the internet) and not at rest (while sitting on a computer), so any files you transfer over Firefox will not be encrypted at-rest on whatever computers they get on unless you encrypt them to be before sending them, or they are saved onto a device that is itself encrypted. This is the default configuration.

When you transfer files from your encrypted Linux or Qubes OS machine onto a USB stick, they are being copied in cleartext to the USB stick, meaning anyone can view them because they are not encrypted at all. This is the default situation and it only changes if you have also encrypted the USB stick and copied the file into the encrypted container. This is the same situation you might have on Windows if you have Bitlocker’s encryption enabled. Both Bitlocker on Windows and dm-crypt/LUKS are forms of system-level encryption; they both encrypt your computer’s data at rest when turned off, and are unlocked during boot and login.

If you have not deliberately encrypted your USB stick or the files you copied onto it, then the reason why you may not be able to access the USB stick to see your files is because Windows is not recognizing a valid filesystem format. This can either be because you did not format the USB stick (and so it is being used as a raw unformatted data device, something natively supported on Linux but not Windows) or you formatted it using a filesystem that Windows does not natively recognize, such as ext3 or ext4. These are common default filesystem formats on Linux systems, including Qubes OS, and so may be the default format implemented by the USB stick formatting software you use on the USB stick.

Windows natively recognizes FAT (eg FAT32), exFAT, and NTFS filesystem formats, but not any from the ext family, even though Linux can recognize almost any filesystem format. So, if the problem is with Windows not identifying your USB stick as having a valid filesystem format, then reformatting the stick to FAT32 or NTFS should fix it. Reformatting will remove your data off the stick, however, so you will need a backup of it to copy back on after reformatting it.

If your problem has to do with something else, such as the files on your USB stick actually being encrypted or otherwise unintelligible to you even when you successfully open it on Windows for browsing, then you will need to clarify what you mean.

If I am mistaken about my interpretation of your problem, then I apologize and also recommend you clarify what you mean.

Kindest regards,
John

1 Like