Cannot disable the dom0 XScreenSaver 5.4.3 locking

Qubes 4.0.3 using fedora-30 in dom0. I have set every possible screensaver and power setting, that I find in the gui menu system to suit my power and screensaver needs. However I am still finding the screensaver locked at times. As my Qubes installation is on my desktop computer and nobody else has physical access to the system, I would like the locking feature disabled. I assume this will need to be done from the dom0 Terminal. Is there a command to accomplish this? Thanks.

I don’t know the answer, but since XScreenSaver is not Qubes-specific, you might be able to find a general XScreenSaver solution that also works on Qubes.

xfce menu -> System Tools -> Screensaver

  1. Mode: Disable Screen Saver
    or
  2. Disable “Lock Screen After x minutes”

Another method for this is to check the “presentation mode” option in
the power management applet.

Thanks for the suggestions friends.
Andrew: Following your suggestion, I did a websearch and found an XScreenSaver page, which led me to the dom0 .xscreensaver config file, which I opened with vim. All settings looked fine to me.
Johnboy: I had previously disabled the Screen saver in the xfce menu --> System Tools --> Screensaver
Jarrah: I had also checked the xfce Power Manager option in the Qubes menu system and in the System subsection had made sure the Lock option was unchecked. However I do not see any “presentation mode” option there. Maybe I’m missing it, but it doesn’t seem to be present in my system.
I am still finding the XScreenSaver wanting my user password to open the screen after the screen blanks out. Don’t see why this is, considering the settings made.

Jarrah: I had also checked the xfce Power Manager option in the Qubes menu system and in the System subsection had made sure the Lock option was unchecked. However I do not see any “presentation mode” option there. Maybe I’m missing it, but it doesn’t seem to be present in my system.

I’m on I3, not XFCE, so I can’t comment on exactly where it will be, but
I’m talking about the battery/power icon in the tray/task bar. I don’t
believe it comes from i3.

Ah, I see I think Jarrah. But I’m on a desktop box and don’t have the battery/power button in my tray. Might a removal of the XScreenSaver program in dom0 and then reinstallation of it cure the problem? Or might that break the system, when removed?

xset s off in a dom0 terminal should do it for the current session.

See [1] (xset applies for all X server platforms).

[1] https://askubuntu.com/questions/67355/how-do-i-completely-turn-off-screensaver-and-power-management

Thanks for the suggestion tripleh. I opened the Packages program from the Qubes menu and searched for xscreensaver. That listed the screensaver program as xscreensaver-base-1:5.43-1.fc25 (64bit) . I clicked on Remove to get the critter out of there. A reboot and so far all seems good. I usually manually turn the screen off, when I leave the room anyway. If anyone has any suggestions on a persistent fix, I’ll reinstall xscreensaver to try it out. Otherwise I’ll continue like this for about a week and then probably reinstall xscreensaver, to see if the same behaviour occurs over time. cheers

I don’t know if it helps, but I have the same problem. I am currently trying a new workaround, and it seems to do the trick :
Go to the ScreenSaver GUI (System Tools > Screensaver).
Then, go to File > “Kill Daemon”.

Plus, go to the System Tools > Session and Startup and untick “Screensaver (Launch screensaver and locker program)”

And I also did the same trick as you did in the Power Manager (untick the Lock option in the Security tab). I am considering also changing the timeouts (blank screen and so on), if the previous measures don’t work.

Anyway, I hope it helps, and am currently not sure if it’s working for me, but so far, so good on my computer.

Cheers !

Thanks fdd. It’s been about a week now with the default installation’s screensaver program completely uninstalled and the system has been trouble free. I had been worried, that the XScreensaver program might have somehow been linked to the system Power settings and that removing it might break the system. But that seems not to be the case. As the Qubes installation is on my main desktop computer and nobody else has physical access, turning off the monitor hasn’t been a great inconvenience, when the system won’t be used for some time. I will reinstall the screensaver program, as I had intended after a week without it and see if the prior misbehaviour reoccurs. If it does, then I will try to reproduce your fix. Either way I shall report back with the results in a few days. Cheers

Hi again,

Looking forward to reading your feedback, then :slight_smile:

Lately, I’ve found that if I just want to watch a movie or something without the screen locking or turning off, it works to make these two changes:

  1. XScreenSaver Settings -> Display Modes -> Mode -> Disable Screen Saver
  2. XScreenSaver Settings -> Advanced -> (uncheck) Power Management Enabled

I usually leave the XScreenSaver Settings window open in the background so that I don’t forget to change the settings back afterward. :slight_smile:

1 Like

adw: Thanks. However I had been using those settings, when I had the default xscreensaver still installed. I expect there was a glitch, maybe (?) from an update and my particular hardware, as the screensaver seemed to be acting up after a week or two of the new Qubes installation.

I am presently trying to reinstall xscreensaver and am having no success. I found this webpage, which has instructions for fedora 30 (my dom0 version):


However in Xfce Terminal the “sudo dnf install xscreensaver” command listed results in the error message, “Failed to synchronize cache for repo ‘qubes-dom0-cached’ , disabling”.
I’m at a loss, as to how to resolve the cache problem and reinstall the xscreensaver.

Since you’re trying to install it in dom0, you’d have to do sudo qubes-dom0-update xscreensaver instead. See:

Thanks so much Andrew. I had missed that dom0 installation method. I now have xscreensaver reinstalled successfully and have set the screen to blank after 60 minutes, recycling in 10 with the “Lock screen after” feature disabled. The Xfce Power Manager is still set to not lock the screen when going to sleep. Will report back in a week if there are no further hiccups. Cheers